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1. INTRODUCTION TO BUILDING A WEBSITE 

� What is Nvu ? 

Finally! A complete Web Authoring System for Linux desktop users as well as Microsoft 
Windows and Macintosh users to rival programs like FrontPage and Dreamweaver. Nvu 
(which stands for "new view") makes managing a web site a snap. Now anyone can 
create web pages and manage a website with no technical expertise or knowledge of 
HTML.  

 

� The big picture 

The first thing you need to understand is how your web site fits 
within the "big picture" of the Internet. Putting together a web page 
is only part of the process. If you look at the image on the right you 
will see that your computer running Nvu is only one piece of the 
puzzle.  

When people browse the World Wide Web they do not connect to 
your computer to view your web site. In order to view a site on the 
World Wide Web you must first put it on a Web Server.  

You use your computer to create the web site and then you Publish 
or upload it to a Web Server.  

The other people who are on the Internet can then connect to the 
Web Server to view the site.  You use software called browsers, 
such as Netscape or Internet Explorer, to connect to and display 
pages of information supplied by remote servers.  

 

� What is HTML? 

HTML stands for Hypertext 
Mark-up Language. It consists 
of text and instructions and is 
what is actually saved. 

You can see any web page's 
HTML by selecting the 
'document source' (Netscape) 
/ 'source' (Internet Explorer) 
option from the View menu on 
your browser. 

As you can see, HTML consists of text and <tags> (the instructions) - the actual page 
stored doesn't look like the displayed page. 

It is no longer essential to know HTML, because of WYSIWYG (What You See Is What You 
Get) editors (like Frontpage, Dreamweaver, Nvu), which generate the HTML for you.  So 
editing of pages and making web creation is as easy as typing a letter with your word 
processor. 
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� Steps to Setting Up Your Own Web Site 

a) Purchase a Domain Name (if desired) 

A "www.somewhere.com" name for your web site is called a domain name. Before you can set up 
a public web site you have to purchase a unique domain name. These are sold by domain 
registrars and you typically pay for them by the year (e.g http://www.hostway.com/).  The first step 
is to check to see if the name that you want is available.  

If you don’t purchase a domain name, then you just use the URL given to you by the web server. 

 

b) Sign Up for a Web Hosting Service: 

In order to run your own web site you need both a domain name and a web hosting service or a 
web server. You should sign up for web hosting service, you can choose for a played account or a 
free account, which will have more limitations (e.g. . http://www.50webs.com/). 

The important information that you will need to know is the "FTP Settings" of your account — you 
will have to type this info into Nvu to publish.  

 

c) Create Your Web Site 

The next step is to actually build your web site using Nvu.  It’s best that you start off simple while 
you are learning how to use Nvu. As your knowledge and skills increase you can start to build 
more sophisticated web sites.  The more complicated your web site, the more knowledge and 
understanding of HTML and the Web you will need to have.  

We recommend the following guidelines when building your web site: 

   • Store all of your web pages and images in the same directory 

   • make subdirectories to make your site well-organized 

   • Only images in the format: .gif, .jpg, and .png are usable on the web 

   • Do not use spaces and capital letters in your file names 

   • Your web pages can have the extension .htm or .html but you should pick only one 

 

d) Publish (Upload) Your Web Site 

Before you (or anyone) can view your web site on the Internet you need to publish (or upload) your 
pages and images to your web server. You will use the settings from your web hosting service to 
enable Nvu to publish your site to the web server.  

 

e) Let People Know About Your Site 

After you create your web site you will want to tell others about it. The best way to do this is to 
open your web browser and type in the address to your web site. After the site loads you can copy 
and paste the web address (called a URL) to your email program and send the link to friends and 
colleagues. If you would like to make your site more accessible to other people on the Internet you 
will have to get it listed in Search Engines like Google. Here are some search engines that you can 
publish your new site to. Just follow the links below and submit the URL to your new web site: 

   • Google - http://www.google.com/addurl/ 

   • The Open Directory Project - http://www.dmoz.org/add.html 

   • MSN Search - http://search.msn.com/docs/submit.aspx 

   • Yahoo Search - http://submit.search.yahoo.com/free/request  
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2. QUICK START WITH NVU 

� Finding your way around Nvu 

Open Nvu 

double-click on the Nvu icon on the desktop  
or Click on the Start Button           on the taskbar, move up to the Programs option and select 
    Nvu from the menu of Programs that appears. 
 

The main window opens. At the top are a number of toolbars. The topmost is the Menu Bar. This 
carries a number of items (File, Edit etc) used to make selections. The next is the Composition 
Toolbar  which carries a number of ‘Buttons’ labelled ‘New’, ‘Open’ etc.  And below you have 2 
Format Tollbars.  At the bottom of the window is the Status Bar. 

 

To ensure that everything is visible select View > Show/Hide and see that each of the following is 
checked: Composition Toolbar, Format Toolbar, Edit Mode Toolbar, Status bar, Rulers, Site 
Manager. 

Across the centre of the window are two panes: the Site Manager on the left and a blank web 
page on the right. The Site Manager can be closed. 

At the top of the Page area there is a Page tab which carries the name of the page (‘Untitled’). If 
you had several pages open, as shown in the figure, this tab would allow you to select one them 
rapidly. 

At the bottom of the page area is the Edit Mode Toolbar which carries four tabs which select one 
of four ‘Viewing modes’ for a page (‘Normal’, 'HTML Tags', 'Source', 'Preview'.) 

Note The figure shows the buttons as they appear when Nvu is first installed. They may be 
customized to different arrangements.  To restore defaults click View – Show/Hide > Customize 
Toolbar > Main Toolbar > Restore Default Set and repeat similarly for the Format Toolbar. 
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� Setting up your website 

It’s best that before you start creating webpages, 
you first decide where you want to save your 
website. 

Set up website 

� open Site Manager 
� click Edit Sites, this opens the ‘Publish Settings’ 

window 
� enter a convenient name for the site in the box 
Site Name 

� In the Publishing server area click Select 
directory and browse to the folder where the site 
will be located 

� Click the Create Folder Button, choose a folder 
name and click OK 

� Leave the other boxes (Web site information, 
User name etc.) blank. 

 

Back in Site Manager in the column headed ‘Name’ 
the new site should be listed and can be expanded 
to show its contents. 

 

� Saving a Page 

Save a page 

on the Composition toolbar click Save 
 

If it was a new document a dialog window will ask you to enter a title for the page. This will appear 
in the tab at the top of the page display area. NB this is NOT the file name.  Click ‘OK’; you will then 
be offered a normal save window which allows you to browse to a suitable location and name the 
file. The file type offered will be HTML. 

 

� Opening an existing page 

Open a page 

on the Composition toolbar click Open 
 

 

� Creating a new page: 

Create a new page 

on the Composition toolbar click New 
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3. EDITING A WEB PAGE 

� Working with Text  

Many editing functions are very similar to those in a word processor. The top four toolbars on the 
Nvu application window  provide a number of editing functions – to see what any do hover the 
cursor over an item and a hint will appear. 

We’ll discuss a few of the possibilities below. 

 �  �  � � � � � � 

 
 

 	  
 
 

� Standard Text Formats 

To format text in a standard element format 
select the text and click the first drop-down box 
on the format toolbar. This offers a selection of 
standard text formats. Paragraph is the most 
appropriate for general text. 

Once formatted as a paragraph, when typing in 
a text area, use of the ‘enter’ key starts a new 
block of text i.e. a paragraph. To start a new line 
within the current paragraph press Shift+Enter; 
this generates a line break. 

Other standard text formats are Heading 
formats from Heading 1, the largest, to Heading 
6, the smallest. Browsers generally render 
headings in bold type. 

 

� Choose color for Text and Background 

� Choose highlight color  

� Smaller or larger font size 

� Bolt, Italic or Underline 

� Numbered or bulleted List  

� Choose Text Alignment: left, centered, 

right or justified 

� Choose Text Indent 

	 Choose a font 


 Emphasize and strong emphasize 

The emphasis button will result in italicised text 
with most browsers and the strong emphasis 
button in bold text 

 

� Special characters  

By special characters we refer to characters which do not have an equivalent 
keyboard key. HTML supports a large range of characters including all the 
international currency symbols. A number of the more common, including 
accented ones, may be inserted using Insert Menu. 

Insert Special Character 

� Click Insert Menu > Characters and Symbols 
� Choose the character and click Insert 
 

Nvu does not directly support ‘smart quotes’ but text which has been copied 
from applications like Microsoft Word or OpenOffice.org which include smart 
quotes will retain these details and they will be correctly rendered in browsers. 
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� Checking Spelling  

The spell checker will work sequentially through the page. You will be offered one dictionary 
(English United States) but you can add your own words to it. 

Check Spelling 

on the Composition toolbar click Spell  
 

By first highlighting a section of a page only that section will be checked.  It is also possible to run 
the spell checker all the time. Any miss-spelled words will be underlined in red.  BUT Spell checking 
uses enormous processor resources. When working on long documents, if your system grinds to a 
halt, disable this when not required. 

Check Spelling all the time 

� on the Menu Bar select Tools > Preferences 
� in the Options window which appears select the 'Advanced’ button and set ‘Underline 
misspelled words’ – OK 

 

 

� Browsing a page  

You can see how your page will look in your default browser. 

Browse a page 

on the Composition toolbar click Browse  
 

 

 

4. WORKING WITH IMAGES 

� Inserting images 

With Nvu it is easy to insert images on to your page. Browsers accept images in three formats ‘gif’, 
‘jpg’ or ‘png’. You may have to use a graphics package to get your image into a suitable format. You 
can insert an image located anywhere on your computer but, for the sake of order, it is a good idea 
to locate any images which you intend to use either in the same folder (directory) as your page 
document or in a sub-folder of this. 

Insert an image 

� set your cursor where you want to insert the image 
� Click the Image button on the Composition toolbar 
� The Image properties window opens. Click Choose File and browse and select a file 
� Click ‘Open’. Leave checked the box ‘URL is relative to page location’ (this will allow you to 

move the page and image to another location, as you will have to when you upload them to a 
server) Note If the box is ‘greyed out’ this is probably because the page has not yet been saved 

� In the box labelled ‘Alternate text’ add a description of the image. (This forms the ‘alt’ attribute 
for the image and provides text which will appear in place of the image in case of problems) 

� In the box labelled ‘Tooltip’ you may optionally insert a ‘Title’ attribute for the image. Some 
browsers will show the text provided when the cursor hovers over the image. 

� Click OK. 
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� Positioning and resizing images 

You should see the image inserted into the middle of the paragraph. Maybe it has come out some 
ridiculous size.  

Resize an image  
� Click the image, a sizing box with 8 graphical handles 

appears around the image 
� Drag on a handle to alter the size of the image  

Note: Dragging a handle in the centre of a side will alter 
the shape of the image which is usually undesirable 

 
more precise control may be achieved via 
� click the image and Click the Image button on the 
Composition toolbar 

� Select the ‘dimensions’ tab 
� Choose custom size and type the desired pixels 
 

Note Ideally images should be produced at the size required rather than resizing them. Importing 
large images and reducing the size wastes bandwidth and slows presentation. Resizing by small 
amounts can introduce undesirable artifacts. 

You can place images in the middle or at the right or left side and have the text wrap round.  

Reposition an image 

� click the image and Click the Image button on the Composition toolbar 
� Select the ‘Appearance’ tab 
� In the Spacing area, set Top and Bottom and/or Left and Right as required 
� In the drop down box ‘Align text to image’ select the required alignment 
� Click OK 
 

Try the various options. The text starting from where the image is inserted will wrap around the 
image.  You may prefer the complete paragraph to wrap. Click on the image and drag the cursor to 
the start of the paragraph, or anywhere else. Moving images is easy! 

You can also put a border of selected width around a image. The border will be the same colour as 
the adjacent text. 

 

 

5. USING TABLES 

Tables allow data – images, links, forms, form fields, other tables, text, etc. – to be arranged into 
rows and columns of cells. 

A table is basically a rectangular grid forming an array of boxes into which the data are placed. The 
rules, between cells, and the border, around the outside of the table, may be either visible or 
invisible. The boxes are called ‘cells’ and may be coloured. The grid layout does not have to be 
regular – the first row may have one cell the second four, the third three; however, when first 
inserted, it will always be regular.  
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� Inserting Tables 

Insert a table 

� On the Composition Toolbar click the Table button        . The “Insert table” window appears. 

� Leave the ‘Quickly’ tab selected and drag out a matrix then click the bottom right cell to 
define the table arrangement. 

� The cells appear on the screen with narrow outlines. 
 

more precise control may be achieved via 
� the ‘Precisely’ tab in the “Insert table” window 
� Specify the number of rows and columns required. 
� Specify the width of the table either in pixels or as a percentage of window size. 
� If a border is required around the table enter the width in pixels otherwise enter ‘0’. If a border is 

specified each cell will also have a border but narrow. 
 

Even more control may be achieved via 
� the ‘Cell’ tab in the “Insert table” window 
� choose the desired:  Alignment of text within cells 
  Wrapping of text 
  Cell spacing - the gap between cells 
 Cell padding - the gap between the edge of the cell and the text within it 
 

Note If later the table border is set to zero these outlines disappear but Nvu in normal view replaces 
them with a red outline. This does not appear in Preview or in a browser. 
 

� Resizing tables 

Tables created using the ‘Quickly’ tab have width set to 100% of the window size.  Tables at full window width 
give the maximum available space for data. The width accommodates to screen or window size. 

It is possible to set the width to a smaller percentage of window size or to a fixed size in pixels. 
Fixed sized tables are inflexible in use and could result in the user having to scroll horizontally to 
read the content so must be used with caution. It is also possible to leave the width unspecified. 
This is likely to result in the best presentation as the browser will set the width to the optimal value. 

Adjust Table Size 

� with the cursor in the table, click the Table button on the composition Toolbar 
� In the Table Properties window select the ‘Table’ tab. 
� The width can be set either as a percentage of window width or in pixels. To leave it unspecified 

clear any number in the width box. 
 

OR drag the sizing handles, the size is specified in pixels. 
 

 

� Colouring tables and cells 

You can adjust the colour of the complete table or any cell. 

Color Table and Cells 

Nvu however provides several routes to colouring tables or cells. These include: 

� Right-click on table and select Table Cell Properties 
� Use Table button to open Table Properties window. 
� Right-click in table and select ‘Table or Cell. Background Color’. 
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Setting the cell background colour for adjacent cells to a dark colour reveals gaps between the 
cells.  This may be convenient if the cells are to be filled with text as it avoids two items of text 
abutting each other.  At other times it is a problem.  You can control The gap by the ‘Cellspacing’ 
attribute. 

 

� Background Images 

It is possible to set a background image for a table or cell.  The image appears behind anything else 
in the table. If the image is larger than the table the table is unaffected i.e. does not grow to 
accommodate the image, as much of the image as will fit is displayed. If the image is smaller than 
the table several options are offered e.g. the image may be centred or tiled horizontally, or vertically 
or in both directions until it fills the table. 

Add a background image to a table 

� On the Status Bar right-click on the table or cell (td) tag 
� Select ‘Inline Styles’, ‘Background Properties’. 
� Click Choose File 
� You can then select the tiling and/or position properties as required. 
 

Note When setting a background image, you should also specify a background color that will be 
used when the image is unavailable. When the image is available, it is rendered on top of the 
background color. (Thus, the color is visible in the transparent parts of the image).  

 

� Adding, deleting cells, rows and columns 

Add, delete cells, rows. columns 

right-click on a cell and S 
� Select Table Insert’ to add rows, columns, individual cells or even tables into a cell 
� Select ‘Table delete’ to delete rows, columns, individual cells, cell contents or the entire table 
 

Note Each cell, when clicked, reveals a set of six manipulation symbols (triangles and circles with x inside), 
these provide a rapid method of inserting or deleting rows and columns of cells as shown in the figure. 

 

� Aligning  

Browsers normally display text aligned left and, in the vertical dimension, in the middle of the cell.  

Adjust Text alignment in cell 

� place the cursor in a cell or select all cells and click the Table button 
� choose the desired alignment in the Content Alignment area 
 

Align Table 

� place the cursor in the table and click the Table button 
� select ‘Table’ and set ‘Table Alignment’ to left, Center or right 
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� Merging / splitting cells  

Cells can be joined with (an) other cell(s), thus merging the cells. Virgin cells cannot be split but joined cells can.  
If adjacent cells (whether within a row or column) are selected together they can be joined. 

Merge / split cells 

� Select the cell(s) you want to join / split and right-click 
� Choose join selected cells or split cell 
 

 

� Inserting Text 

After selecting a piece of text Nvu offers a useful facility to convert selected text into a table. Lines 
of text (whether terminated by line breaks or paragraph ends) will be converted to table rows, a new 
cell being generated each time the specified character is met. This allows tabbed lists to be created 
and overcomes the fact that HTML does not support tabs – Simply type a hyphen (or some other 
character) instead of the tab and convert the text to a table. 

Convert text into table 

Select Table > Create table from selection 
 

Using this method tables may be imported from applications like MS Word. In Word convert the 
table to text separating using a character that does not appear in the text. 

 

 

6. LINKS 

Links provide the main means of navigating web sites. They allow you to move quickly from one 
place to either another on the same page, a different page on the same site or a page on an 
external site. Links may be attached to any element on a page, in fact almost any part of a page 
content can form the basis of a link an element being generated specifically for the purpose. Usually 
however we use a few words of text or an image which we click on to activate the link. 

 

� Linking to an internal webpage 

Create an interal link 

� Select (highlight) the text or image you want to act as link 
� On the Composition toolbar click on the ‘Link’ button 
� The ‘Link Properties’ window opens 
� Click on 'Choose File' and browse to the file that you want to link to. 
� Click OPEN and Click OK 
 

In Normal or Preview mode you will now find your text underlined and in a different colour (probably 
blue) You can now try double-clicking on the link, you will see the 'Link Properties' pop up again. 
This can be very useful if you want to change the file to which the link refers. (In a browser you 
would expect the file viewed to be replaced by the one to which the link refers!) 
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� Linking to another website  

You can also, and extremely usefully, link to other web sites.  

Create an external link to  

� Open the Link Properties window opens  
� enter the full URL and uncheck the box ‘URL is relative to page location’ 
 

Be very careful about getting the URL correct,  the easiest way is to copy the address in your 
browser.  

 

� Inserting an email-link 

Instead of linking to a file it is possible to insert an email address. The result will be that, in use, 
when the link is clicked the email client on the visitor’s machine will be opened with the correct 
address selected. 

Create a email-link 

� Open the Link Properties window opens  
� enter the email address and check the box ‘The above is an email address’  
 

 

� Inserting named Anchors 

There is a second type of link, the ‘Named anchor’. Such an anchor  or bookmark is extremely 
useful as it can act as a link to a particular place on a page. 

Create a named anchor 

� Place the cursor at the point you want to mark.  
� Click the 'Anchor' button on the Composition toolbar  
� The named anchor properties window appears. 
� Enter a unique name for the anchor and Click OK. 
 

Linking to named anchors 
� Open the Link Properties window opens  
� instead of choosing file use the drop down list, your anchor name should appear there 

preceded by a “# 
� Click it and OK 
 

In 'HTML Tags' view this time the yellow marker has a picture of an anchor, the anchor is also 
visible in Normal view (but not in Preview). 

If you test your page on a browser when you click the link the view should move to show the 
position of the anchor. 

Note If your page is short you may not notice this. You need to test with a long page with the link 
towards the bottom and the anchor towards the top. With most browsers the anchor should be sit 
on the top visible line. 
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� Link colours 

Links are normally underlined and in blue text. If you look 
carefully you may see the colour change and wonder why. 
Links can exist in several states the principal are:  

unvisited links: the initial state 
visited links: have been visited in the past 
hovered: cursor now hovering over 

While these probably appear in different colours it is the 
browser which determines this. 

Change link colours 

� In the menu bar click Format > Page Colors and 
Background B 

� Choose the colors 
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7. STYLE AND STYLESHEETS  

7.1 Introduction to style  

There’s a nice tutorial on html at http://www.w3.org/Style/Examples/011/firstcss.en.htmlhttp://www.w3.org/Style/Examples/011/firstcss.en.htmlhttp://www.w3.org/Style/Examples/011/firstcss.en.htmlhttp://www.w3.org/Style/Examples/011/firstcss.en.html 

 

� Styles 

Styles specify how particular elements on a page appear. By ‘elements’ we mean parts of the page 
structure, typically headings and paragraphs, but also stretching to many others including tables, 
bulleted and numbered lists etc. In fact most HTML ‘Tags’ may be specified though the same style 
may be applied to several. 

Example: 

 
 

� Classes 

As well as allowing you to specify the style of elements it is possible to define styles and apply them 
selectively to only some elements.  This is done through ‘Classes’ – a ‘Class’ is just a style that can 
be applied as and when you choose.  

‘Classes’ are applied to ‘Tags’ (a marker attached to an element). The element to which the class is 
applied appears in the format defined by the class. Other similar elements without the class applied 
appear in the default format i.e. either the default specified by the browser or the style that the user 
has defined for the corresponding element.  

Example: 

 

 

� The ID attribute 

You can also apply a style to a unique HTML element.  The id must be unique within the HTML document. 
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Example: 

 
 

7.2 Using style  

Within a page styles may be used in three ways. These ways can be mixed and matched as you wish. 

 

a) Inline style  

The first, easiest is to define a style there and then. Such a style is listed in the code (in Source 
view) with the tag to which it applies (using the structure “style = S.”).  Don’t worry Nvu hides all 
this from you.   

If you have an other item with the same style this code must be repeated. This bloats the page. This 
is known as an ‘inline style’.  

Example: 

 

 

b) Internal style  

The second way to use a style is to embed a list of style definitions within the HEAD section of a 
page. (These definitions are referred to as 'style rules' or just 'rules')  

These rules  may be of one of two sorts. The first sort applies to all elements of a particular type, 
the second is the class as discussed above.  
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c) External style – Linked stylesheets  

While the first two methods are valid and have their uses, the third is the preferred method 
specifically because it is economical, reuses the same styles for many pages and helps in achieving 
consistency of appearance right across a complete web site. The method uses an external style 
sheet which is ‘Linked’ to a page, or to several pages (though each page must include the linking 
information for itself).  

An external style sheet contains the same list of rules as would otherwise have been included in the 
internal list referred to above. (It is actually a simple text document such as you could construct 
using a text editor like Windows Notepad.) The file is usually located in the same folder as the page 
to which it is linked (though it can be elsewhere) and has the extension ‘css’.  

How does a page know to use this style sheet? A line of code which, Nvu will insert for you in the 
head section of your page, will see to this.  

The code looks like <link rel="stylesheet" type="text/css" href="mystylesheet.css>  
The stylesheet “mystylesheet.css” will be saved in the same folder as the html page. 

 

d) Cascading style sheets  

You may wonder – if you have an external style sheet, perhaps internal rules and inline styles will 
there be confusion? This is where the cascading comes in. Your browser should first use whatever 
its default style would be. If it finds a matching style in an external sheet it should use that instead, it 
should then look at internal styles and, if any coincide with anything it is planning to use that should 
override them. Lastly inline styles prevail. 

How could that be used? Well perhaps your site establishes a style using an external style sheet. 
Perhaps you have one page about emergency procedures and you decide that all its paragraphs 
should be in red. You simply add an internal rule on that page redefining the ‘p’ tag to be red but 
also link the page to your normal style sheet. All your normal styles will be applied except that all 
paragraph text will be in red, nothing else will  be non-standard. 

 

7.3 Creating styles with Nvu 

� Internal styles  

Styles are created and edited using the built in Style sheet editor called CaScadeS. CaScadeS has 
two modes of operation ‘Beginner Mode’ and ‘Expert Mode’. When it opens it opens in expert mode, 
should you wish to switch to Beginner Mode clear the check box. The difference is that in Beginner 
mode External style sheets cannot be created. 

When internal styles are created Nvu will include the rules for these in the 'head' area of the 
document.  

Create Styles 

� Open Tools > CSS Editor. 
� Click 'Style elt', ‘Create Stylesheet’.  
� Click RULE. 
� The General tab opens and offers the options: 
 - ‘Named Style’  
  - ‘Style applied to all elements of type’  
  - ‘Style applied to all elements matching the following selector’. 
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To style an element (e.g. a paragraph): 
� Select ‘Style applied to all elements of type’ 
� In the box type the tag for the element  (without the quotes) (e.g. “p”) 
� Click ‘Create style rule’. 
� In the pane on the left you should see a structure showing each tag as it is defined. 
 
To define how you want elements to look: 
� Click the tag for the element in the left hand pane. 
� The General tab should show the ‘Selector’ (at present the element tag) and any style 

‘Declarations’ (initially blank) 
� Now select in turn as required the tabs for ‘Text’, ‘Background’, ‘Border’ etc and specify exactly 

how you wish that element to appear 
� Return to the general tab to see the full declarations that you have set for the Selector. 
 

You are not obliged to specify any particular properties. You specify as much or as little as you 
wish. It’s just that the browser will revert to defaults if you don’t.  

You may like to try setting declarations for the ‘body’ and apply it to all elements. In most cases 
declarations specified here with trickle down to everything else (they are ‘inherited’) unless you 
specify it explicitly elsewhere. Generally this works but can generate surprises. 

 

� Example 

In the following example we have set the font-color for the element p (paragraph) to white and we 
have set a black background for the body element. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

This is what you would see in the Preview Window: 
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This is what you would see in the Source Window: 

 

 

 

 

 

 

 

 

 

 

� Styling multiple elements  

Instead of setting styles for one element at a time it may be easier to specify several at the same 
time. Perhaps all your headings are in one font (e.g. serif) and all others in an other (sans-serif). 
You can specify h1, h2, h3, h4, h5 and h6 as serif font in a single action by listing them and 
separating by commas after selecting RULE, “Style applied to S” . Later you can specify, for 
example the size of, each heading individually in a separate rule.  

 

7.4 Named Classes  

I’ve suggested above that you start by applying styles to all elements of a specific type. Such style 
definitions will apply automatically wherever that element is found on a page. This provides for great 
consistency within a document but maybe a touch of dullness! You can also define your own styles 
and apply them selectively. These styles are known as ‘Classes’.  

Create Classes 

� Open the CSS Editor, and if necessary create a style sheet 
� Click on the stylesheet to select it. (If there is more than one stylesheet click on the one in which 

you wish to create the class.) 
� Decide on a name for the class (Class names can contain letters, numbers and underscores but 

not spaces and must not start with a number. They are case insensitive) 
� Click on RULE, leave ‘Named style’ selected and enter your chosen class name in the box. 
� Click on ‘Create style rule’. 
� You should see the name of your style appear in the pane on the left but note that the name is 

preceded by a dot (full stop). 
� Now proceed as you did with internal stylesheets 
 

 

‘To define how you want elements to look’. In that case you could watch the effect of your styles 
appear immediately on your page (assuming that you had a page which used the corresponding 
elements). Now, of course, you have none, so first we must learn how to apply a class to an 
element.  

First enter some details for your new class that will allow you to recognise it on the screen if it is 
applied. For instance use the border tab to produce a border styled as solid, 2px wide, coloured red. 
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� Applying Classes.  

 

Nvu provides two methods for applying classes. Method 1 is the simpler; sometimes it is difficult to 
select the item to use this method in which case method 2 is preferable.  

Apply a class - Method 1  

1. If necessary close the CSS editor.  
2. Select the item to which the class is to be applied. For a heading or paragraph simply click in 

the text, to apply a class to an inline section of text (span) highlight the text.  
3. Use the class selector box on the Format toolbar (see figure), click the drop down arrow and 

select the class required.  
4. The result of applying the class should be seen in any view mode.  

Note Although Nvu is not a browser it replicates the browser display very well. However styles 
applied to links are not rendered correctly at present.  

Apply a class - Method 2  

Note This mode cannot be used to create the span element needed to style an inline section of 
text but can style such a section once the span exists.  

1. If necessary close the CSS editor.  
2. EITHER in 'HTML Tags' view Click on the yellow marker for the element for which you want to 

set a class. (If the element does not become selected, as indicated by outlining or highlighting 
on the screen, press the control key while selecting.) 
OR in Normal or Preview mode click in a block you wish to style then click on the Status bar 
on the right-most element listed.  

3. Now both the block involved and the corresponding element and on the status bar should be 
highlighted. (See figure above.)  

4. Right-click the highlighted element on the status bar and select ‘Classes’. You should see a list 
of all classes pop up (This includes classes on internal and linked stylesheets.) Any class 
already applied to the element appears, marked with a tick (✔), at the top of the list above the 
divider line; other available classes are below the line.  

5. To add a new class, click the class;To remove a class, click the class above the divider.  

Note Elements can actually have several classes applied. If you do this you should ensure that 
the class properties don’t conflict with each other. Most people will probably prefer to apply 
only one class at a time. You may need to check that you don’t apply more by mistake.  
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� Removing classes  

A similar procedure may be used to disconnect an element from a class. Using the highlighted 
tag method simply select the ticked class, this deselects it.  Using the class selector box select 
the style again, this should cancel it. Alternatively, after selecting the element, right-click on the 
highlighted tag on the status bar and select ‘Advanced properties. The selected class will be 
listed select it and click ‘Remove’.  

 

7.5 External styles  

There are three ways to start working with external style sheets  

� Create a new external style sheet  

External style sheets are created in almost exactly the same way as internal sheets.  

To create an external style sheet  

1. Open the CSS Editor. (Tools > CSS Editor).  
2. Make sure that you are in ‘Expert Mode’ and Click ‘Style elt.’  
3. Type a title in the box and click ‘Create Stylesheet’.  
4. Click ‘Export Stylesheet S’   
5. Give it a name with extension css and save it, preferably in the same folder as your page.  

Now click on ‘RULE’ and you should be on familiar territory.  

When we created internal styles they were entered on our page in the HEAD section. Now the 
styles are being created in an external file. If you looked, in ‘Source’ View, in the head area you 
would see a line referring to the external file and linking it to your page.  

Warning Unfortunately, at the moment, Nvu makes a meal of inserting the 
filename. It puts the absolute address of the file as it appears on your hard drive. 
When you upload or move your page the stylesheet won’t be found. You will need 
to edit the HTML Source code in the line starting <link rel="stylesheet" (note the 
‘line’, which may spread over several lines, finishes type="text/css">) Delete all the 
code like file:///C:/Documents%20S right up to and including the / before the 
filename. The result should contain text like href="filename.css". If your stylesheet 
is in a sub-folder the text should be like href="subfolder/filename.css".  

 

� Change an internal style listing into an external stylesheet  

If you already have set up your page using internal styles you can convert them into an external 
stylesheet and link to that. 
Open the CSS Editor. In the ‘Sheets and rules’ pane click on the stylesheet and under the 
general tab click on ‘Export stylesheet and switch to exported version’ and proceed.  
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� Link to an existing stylesheet  

If you have a stylesheet that you created for another page or intend to use right across your site 
you can link your page to that. 
To link to an existing external style sheet 

1. Open the CSS Editor. (Tools > CSS Editor).  
2. Make sure that you are in ‘Expert Mode’ and Click ‘Link elt.’  
3. Click ‘Choose file’ and browse to the location of the stylesheet you want to use.  
4. Click 'Open' then ‘Create stylesheet’. You should then see the stylesheet name appear in the 

‘Sheets and Rules’ pane to the left.  

� Saving stylesheets  

Once you have linked and saved a stylesheet, if changes are made later, the changes will appear 
in your document immediately and the sheet will be re-saved when the page is saved.  

 

7.6 Other style selectors  

� Link styles 

Browsers render links in default colours and Nvu provides some options for controlling these (see 
3.7.1.6). Through the use of styles full control of each state of a link is possible. This is achieved 
through the use of selectors called link ‘pseudo-classes’.  

The more important pseudo-classes are 

a:link for all links not yet visited 

a:visited  for links that have been visited 

a:hover for a link over which the cursor is hovering 

Note The following procedures are based on the use of internal style sheets. Very 
similar procedures may be used with external stylesheets.  

To create link pseudo-classes  

1. Proceed as if creating a class (see section 4.2.3)  
2. At step 4 select ‘Style applied to all elements matching the following selector’ and in the box 

enter the selector as listed above.  
3. At step 5 the selector name should appear as entered.  

It is now possible to style these options fully, i.e. not only with text colour and decoration but with 
background, boxes, the lot.  

Note that the a:hover must be placed after the a:link and a:visited rules, since 
otherwise the cascading rules will hide the a:hover rule.  
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The CaScadeS CSS  editor enters styles in the order encountered. The order may be altered by 
selecting an item and clicking the ‘Up’ or ‘Down’ button.  

� Form control styles  

Setting up forms to appear as required may require styles to be set for specific controls. These 
are set exactly as just described for links it is merely necessary to set styles for the required 
selectors. Some of the main ones are listed following.  

Control Element Selector 

Submit button Input input[type=submit] 

Reset button Input input[type=reset] 

Text input Input input[type=text] 

Text area textarea textarea 

Label label label 

Field set fieldset fieldset 

Legend legend legend 

 

7.7 Removing styles  

The CSS editor allows you to remove styles in a similar way to adding them. 
In the ‘Sheets and rules’ pane select the rule you want to remove and click ‘Remove’.  

Similarly you can remove a stylesheet. Select the sheet and click ‘Remove’. If you select an 
internal stylesheet it is deleted from the file completely.  

Warning this deletion is not reversible using ‘Undo’.  

If you remove an external stylesheet the link on the page is removed irreversibly but the external 
file is left intact.  

 

 

7.8 The division <div> element 

The <div> element has been mentioned only in passing so far. A div establishes a division i.e. a 
section of a page to contain a number of elements. (Within the div styles are often applied in 
particular ways as will be touched on later.) The remainder of this section is not intended as a full 
explanation of what a div is or how to use it rather it is an explanation of how to create and 
populate a div using Nvu. Other aspects of divs are likely to be beyond the interest of beginners.  
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� Creating divs  

To create a div  

1. Place the cursor where the div is to be created. 
Note It may be easier to see what is happening in HTML tags view with View > Block outline 
selected.  

2. Click the first drop-down box on the format toolbar.  
3. Click the last option at the bottom of the list - Generic container (div).  
4. The div is created formatted as body text.  

It is now possible to insert any desired item into the div e.g. Text or images. Text may then be 
selected and formatted as paragraphs etc. If required, divs may be inserted so that a set of 
nested divs is produced.  

Sometimes difficulty may be experienced such that elements in a div disappear when an attempt 
is made to populate them. To avoid this it is undesirable to insert empty elements, so either 
insert, for example, one paragraph at a time or enter some dummy text as a placeholder.  

To apply a class to a div  

Proceed in the normal way (see section 4.2.3.1). The class selector box may be used to apply a 
class to a div but it will not display the class which has been set. The preferred method to use is 
via the highlighted tag on the status bar which can be used to add or remove classes.  

To inspect or change a class  

Use the status bar to access the class.  

Elements within a div may have styles applied in the all the normal ways.  

To leave a div  

Click in any area outside the div. This is why a div should never be the last item on a page it will 
be impossible to leave it except to visit an item higher on the page. 

Unique divisions 

A common use of divs is for unique regions of a page. Examples might be a menu, a table of 
contents or the main text area. In such cases rather than applying a class to a div it is more 
appropriate to use an 'id'.  

� Styles within a div  

A div is a useful way of applying a different set of styles within a limited region on a page. Of 
course a set of classes could be designed and applied to the elements within the region but this 
is laborious and bloats the code. A simpler way is to set up a set of styles for the elements in the 
div and to tag them in such a way that they apply only within the div. This is done using an 
appropriate selector. Suppose the div has a class ‘divclas’. Examples of appropriate selectors 
are:  
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div.divclas p 
div.divclas td 
div.divclas a:visited 

Or when using ids  

#menu p 
#contents li  

These may be set up in the same way as for pseudo-classes see section 4.2.5.2.   

� Creating a layer using a div  

In section 3.10.3 we noted that ‘Layers’ are contained in ‘divs’. In fact a Layer is simply a div 
which has a position, and optionally a z-index, style attached. When Nvu creates a layer it does 
so by attaching an inline style to the div.  

It is equally possible to create a layer by setting up an appropriate class and attaching this to a 
div.  

When a layer is created in this way Nvu depicts it as a normal layer and renders it with a 
surrounding box with sizing and position handles. Visually it is indistinguishable from any other 
layer.  

Such layers may, of course be precisely located and are not subject to the vagaries of manual 
dragging.  

Warning If a layer, created using a class, is subsequently dragged or resized, Nvu attaches an 
inline style. Any styling so added will override the class styling.  

 

7.9 The Body 

This is the background on which the whole page sits. The Body may be thought of as the Page 
itself. Normally it is of little concern to the designer but there are a few situations when it is. 

The body can carry a background colour or image which lies behind everything else on the page 
in HTML documents (in XHTML documents, the background content for the body element defines 
only the background for the body element.).Thus the overall appearance of a page can be 
significantly determined by this content.  

To set a background 

1. In HTML tags view click the body yellow marker while pressing the control key.  
2. On the Status Bar right-click on ‘Body’. (This item is exceptional in that you will not see it 

highlighted.)  
3. Select ‘Inline Styles’ and ‘Background properties’.  
4. Make the desired selections and click OK.  
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The ‘Inline Styles’ allows you to set several other properties for the whole page. This includes 
Text, Border and Box properties. This can be a quick way of styling a whole page since Text 
properties, for instance, will trickle down (technically they are ‘inherited’) to everything on the 
page for which they are not otherwise specifically stated. Border and box properties are not 
inherited. 

Inline styles may set the body width to be less than the full window width. In this case it may be 
desired to centre the page in the window. 

To centre a page in the window 

1. In HTML tags view click the body yellow marker while pressing the control key.  
2. On the status bar right-click on ‘Body’ (it will not be highlighted).  
3. Right-click ‘Inline styles’ and select ‘Box properties’.  
4. In the ‘Width’ box select the width desired for the page.  
5. In the ‘Margins’ area in both ‘Left’ and ‘Right’ boxes type ‘auto’.  
6. Click OK.  

Stylesheets (see section 4.4) often set several general properties for the body to avoid having to 
repeat them several times. 

7.10 The Head area 

Every HTML document starts with a “Head” area. This provides information to browsers, search 
engines etc but is invisible on the page. 

Items included on the head are gathered from a number of sources. These may include: 

• Items dependent on the Doctype as set when creating the page (section 3.2.1).  
• Items collected from Page Preferences (section 9.1). Includes Author, Language.  
• Items set by the Format > Page Title and properties menu. Includes Title, Author, 

Description, Language, Writing direction Character set.  
• Links to stylesheets (section 4.1.3.3)  
• Definitions for internal styles (section 4.1.3.2)  

Source view allows advanced users to add further information as desired. 
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8. SITE MANAGER  

� 8.1     Overview 

The site manager allows you to navigate your site or between sites easily. 

To toggle the Site Manager on or off either press F9 or use View > Show/Hide > Site Manager. 

Site Manager can deal with sites irrespective of whether they reside on a local machine or on a 
remote server. In the latter case, if you are on a dial-up network, Site Manager will dial and make 
the connection for you. Since generally you will set up a site on a local machine and later 'publish' 
to a remote sever we will deal first with setting up on a local machine. 

Site Manager provides a directory tree view of a site similar to the view with Windows Explorer. It 
however lists only directories which you have specifically set up as ‘Sites’. You can set up many 
sites, they appear in Site Manager irrespective of where they appear in a normal directory tree. 

� 8.2     Setting up sites 

To set up a new site (assuming that pages for the site have 
already been created) open Site Manager, click ‘Edit Sites’. 
This opens the ‘Publish Settings’ window. 

Choose a convenient name for the site (You may like to call it 
something like “My Site Local” to differentiate it from a later 
“My Site Remote”) and enter it in the box ‘Site Name’. 

In the ‘Publishing server’ area click ‘Select directory’ and 
browse to the folder where the site is located, select the 
folder and OK. The box should read something like 
“file:///C:/Documents .... “ (Ignore the hint line which applies 
to remote sites only.)  

Leave the other boxes (Web site information, User name 
etc.) blank. 

Back in Site Manager in the column headed ‘Name’ the new site should be listed and can be 
expanded to show its contents. 

� 8.3     Site Manager Functions 

The main window lists all sites which have been set up and, for any sites which have been 
expanded, the files contained in it. (See figure.) 
Double-click any site to expand it. 

At the top of the Site Manager window a drop down box allows you to view all files or to select to 
view only html files (which includes htm files) or only image files (these include gif, jpg, jpeg and 
png files). 
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For files it is possible to display the file size and modified date. To select or de-select these 
options, in the column heading click the right-most division and select the options required (see 
figure). (You may have to widen the site manager window to make this possible.) 
It is not possible to change the order of the listing. 

Double click on any html file to load it directly to the 
page area for editing. 

By using the buttons at the top of the Site Manager window, and selecting a file if required, it is 
possible to  rename and delete files and to create folders. 

Note all these actions alter the actual files concerned. By using the ‘Edit Sites’ function and the 
‘Publish Settings’ window, sites may be removed from the Site Manager but this has no effect 
on the actual folders or files involved only on the view in Site Manager. 

� 8.4     Remote sites 

Remote sites – on the server hosting a site – may be set up in almost exactly the same way as 
local sites (see Section 8.2). This permits the same browsing, display and editing functions as for 
a local site. 

This time all the boxes on the ‘Publish Settings’ window must be completed. Hints are provided 
for the content of each. The HTTP address will be used by the Site Manager to find the site. 

� 8.5   Publish your site 

To begin, open up Nvu and go to the "Edit" menu and select "Publish Site Settings". You must fill in 
these values before you will be able to publish your web site to the web server. The screen will 
look similar to this:  

 

• Site Name: You can type any name you want in this field 

• HTTP Address: This is the address that you type into a web browser to get to your web site 
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• Publishing Address: This is the FTP server information that you get from your web hosting 
service 

• Username: This is the username that you use to connect to your web hosting service 

• Password: This is the password that you use to connect to your web hosting service 

You should disgregard the "Select Directory" button when setting up your web hosting connection. 
This only allows you to select local folders on your computer and has nothing to do with your web 
server. When you are finished setting up all of the settings for your web hosting options click on the 
"OK" button to save the information. After you set up the "Publish Site Settings" whenever you click 
the Publish (or Save) buttons the local changes that you make to your web site will be uploaded to 
the web hosting service (web server). This is the method by which you make changes to your web 
site. First, make your changes locally on your computer using Nvu. Then, when you are done you 
click the "Publish" button to upload the information to your web hosting service. After your site has 
been published you should be able to open a web browser and view your changes. 

 


